Die Funktion ZÄHLENWENN arbeitet sehr ähnlich wie die Funktion SUMMEWENN, beantwortet jedoch andere Fragen.

Zum Beispiel: Wie häufig ein Mitarbeiter Urlaub genommen hat?

Dazu zählt die Funktion einfach jedes Vorkommen des Eintrags eines Mitarbeiters.

Die Funktion lautet:

=ZÄHLENWENN(Bereich;Suchkriterium)

Um unsere Frage nach der Urlaubsanzahl zu beantworten, wird die Funktion mit folgenden Argumenten bestückt:

=ZÄHLENWENN(C6:C19;F6) Der Bereich umfasst alle Ausgabenpositionen, die durchsucht werden sollen – und zwar nach dem Wort, das in Zelle F6 steht.

Genauso gut könnte man auch direkt nach dem Begriff "Urlaub" suchen oder nach den Buchstaben "u".

 

Urlaubstage mit Zählenwenn Funktion zählen

Als Beispiel können Sie die genommenen Urlaubstage mit der ZÄHLENWENN Funktion zählen. Dazu erstellen Sie erstmals eine Tabelle mit allen Mitarbeiternamen.

Meine Tabelle

Meine Tabelle

 

 

In der grünen Zeile sollen die Urlaubstage von Herrn Müller, Herrn Mustermann und Frau Musterfrau von 01.02.2010 bis 17.02.2010 mit Hilfe der Zählenwenn Funktion ermittelt werden.

Sie können natürlich auch die Urlaubstage für das ganze Jahr zählen lassen.

 

 

 

 

 

Formeleingabe

Zählenwenn Funktion

Zählenwenn Funktion

Um die Urlaubstage mit Hilfe der Zählenwenn Funktion zu ermitteln, geben Sie in die Zelle B2 folgende Formel ein:

=ZÄHLENWENN(E3:E19;"U")

Um die Zellen von E3:E19 einzutragen müssen Sie diese nicht über die Tastatur eintragen, Sie können einfach die gewünschten Zellen mit Maus markieren und schon übernimmt Excel die Zellen.

Ich habe ein "U" in die Formel eingetragen. Das bedeutet das Excel jedes Mal wenn Sie ein "U" (wie Urlaub) eintragen die Anzahl von eingetragenen "U" automatisch zählt.

Wenn Sie die Formel eingetragen haben, erscheint eine Null (0), was normal ist da noch kein "U" in den Zellen E3 bis E19 eingetragen ist.

Sobald Sie ein "U" eintragen, zählt Excel die eingetragenen "U". Um die Formel für alle weiteren Mitarbeiter zu benutzen, ziehen Sie einfach die eingetragene Formel in die anderen Zellen (C2 und D2).

Urlaubstage

Urlaubstage

 

 

Wenn Sie die Urlaubstage von jedem Mitarbeiter eintragen, zählt Excel automatisch die Tage.

Aus der Tabelle können Sie sehen dass:

  • Herr Müller 2 Urlaubstage genommen hat.
  • Herr Mustermann 5 Urlaubstage genommen hat.
  • Frau Musterfrau 4 Urlaubstage genommen hat.

 

 

 

 

Arbeitstage mit Zählenwenn Funktion zählen

Formeleingabe

Formeleingabe

Sie können auch eine Tabelle erstellen um Ihre Arbeitstage zu zählen.  Ich habe eine Tabelle für das ganze Jahr erstellt, da die Tabelle sehr umfangreich ist sehen Sie hier nur die Tabelle bis 16.01.2010.

Arbeitstage zählen

Geben Sie in die Zelle B2 bei Monat Januar folgende Formel ein:

=ZÄHLENWENN(B14:B44;"gearbeitet")

Um B14:B44 einzugeben markieren Sie den ganzen Monat Januar (also die B spalte neben dem Datum 01.01.2010 - 31.01.2010).

Wenn Sie jetzt in der Spalte B in Monat Januar gearbeitet haben wird Excel automatisch zählen wie viel Tage Sie gearbeitet haben. So tragen Sie auch die Formel für jeden Monat ein.

Für Monat Februar tragen Sie folgende Formel ein:

=ZÄHLENWENN(B45:B72;"gearbeitet")

Video

Hier ein Video der Ihnen die Arbeit mit ZÄHLENWENN Funktion erleichtern wird.

Hinterlassen Sie einen Kommentar!

Interessiert Sie eine andere Excel Funktion?

Weitere Tipps und Tricks nehme ich gerne in den Kommentaren entgegen.