Datum- und Zeitberechnung mit Excel

Mit Excel Formeln und Funktionen, können Sie Berechnungen mit Datums- und Zeitangaben vornehmen.

Datum und Zeit Funktionen konvertieren jedes Datum und Uhrzeit in ein serielles Wert, die addiert und subtrahiert werden und dann wieder in ein erkennbares Datum oder die Uhrzeit umgewandelt werden können.

Excel berechnet ein Datum als die Anzahl der Tage nach dem 1. Januar 1900, so dass jeder Tag durch eine ganze Zahl dargestellt werden kann. Excel berechnet eine Zeit in Einheiten von 1/60 einer Sekunde. Jede Uhrzeit, kann als ein serielles Wert  zwischen 0 und 1 dargestellt werden.

Zeitberechnung

Die Einbeziehung von Uhrzeit und Datum in Excel-Berechnungen ist nicht ganz einfach. Die automatische Konvertierung und Formatierung bringt manchen Gelegenheits-Anwendern zur Verzweiflung.

Um Ihnen leichter die Zeitberechnung in Excel zu erklären werde ich die Reisezeit in Excel berechnen:

  • Erstellen Sie erstmals eine Tabelle:

    Reisezeit Tabelle
    Reisezeittabelle
  • Wenn Sie die Tabelle erstellt haben, geben Sie dann die Abflugzeit und die Ankunftszeit ein.

Uhrzeiten werden folgendermaßen eingetragen: z.B. 02:00 (Morgen) und 14:00 (Mittag) oder 10:00 (Morgen) und 22:00 (Abend)

  • Ich habe folgende Abflug-und Ankunftszeiten eingetragen:

    Zeitangaben
    Zeitangaben

Berechnung der Reisezeit:

  • Die Reisezeit wird mit der Formel: = Ankunftszeit – Abflugzeit = Reisezeit ermittelt

    Reisezeit
    Reisezeit
  • Die die ganze Reisezeit Spalte muss dann in Uhrzeit Format formatiert werden.            Formatierung: Rechter Mausklick – Zellen formatieren-Uhrzeit.

    Zellen formatieren
    Zellen formatieren
  • Nach der Formatierung wird die ganze Reisezeit Spalte in Uhrzeit Format angezeigt:

    Reisezeit
    Reisezeit

Bisher war es einfach die Reisezeit zu berechnen da die Ankunftszeit immer am gleichen Tag wie die Ankunftszeit war. Wie ist es wenn die Ankunftszeit erst am nächsten Tag ist?

Beispiel:

Abflugzeit um 23:15 Uhr und die Ankunftszeit am nächsten Tag um 06:00 Uhr.

  • In der erstellten Tabelle ändern Sie die Abflugzeit (Zeile A2) und die Ankunftszeit (Zelle B2) in folgende Uhrzeiten:
Reisezeit
Reisezeit

 

Abflugzeit (Zeile A2) = 23:15 Uhr

Ankunftszeit (Zeile B2) = 06:00 Uhr

 

 

 

  • Die Reisezeit wird in der Zeile C2 mit der folgenden Formel ermittelt:

     =WENN(B2-A2<WERT(„00:00“);WERT(„24:00“)-A2+B2;B2-A2)

  • Nach der Formeleingabe sollten Sie folgende Reisezeiten bekommen:

    Reisezeit
    Reisezeit

Wenn Sie in eine Zeile die Reisezeit berechnen, die restlichen Zeilen können Sie ganz einfach durch ziehen ermitteln. So müssen Sie nicht in jede Zeile die Formel eingeben.

24 Std. Reisezeit berechnen

Wenn Sie mehr als 24 Std. Reisen dann können Sie auch die Reisezeit mit Excel berechnen.

Beispiel:

Zelle A2 = Reisebeginn am 01.07.2012 = 08:00 Uhr
Zelle B2 = Reiseende am 02.07.2012 =  12:00 Uhr

Formel:

=WENN(B2-A2<WERT(„00:00“);WERT(„24:00“)-A2+B2;B2-A2+WERT(„24:00“))

Wenn Sie das Ergebnis haben, bitte die Zelle formatieren. Rufe Sie den Befehl Format – Zellen – Zahlen auf und erstellen Sie folgendes benutzerdefiniertes Zahlenformat: [hh]:mm

Verpflegungsmehraufwand berechnen

Der Verpflegungsmehraufwand ist der Verpflegungszuschuss bei Auswärtstätigkeit, auch Auslöse, Spesen oder Tagegeld genannt, der anfällt wenn eine Person außerhalb der privaten Wohnung und der regelmäßigen Arbeitsstätte beruflich tätig wird.

Sie sehen hier eine Übersicht der Pauschbeträge für Verpflegungsmehraufwendungen für Deutschland 2012 im Überblick:

Zeitumpfang ab 8 Std. ab 14 Std. ab 24 Std.
Pauschbetrag Verpflegungsmehraufwand 6,00 € 12,00 € 24,00 €

Damit Excel den Verpflegungsmehraufwand anhand von Ihrer Reisezeit automatisch erkennt und den entsprechnenden Verpflegungsmehraufwand berechnet sollten Sie eine Reisezeittabelle erstellen.

Beispiel:

Reisezeittabelle
Reisezeittabelle

Nachdem Sie die Reisezeittabelle erstellt haben, beginnen Sie mit der Formeleingabe.

Beschreibung Formel
Reisezeit Zelle C4 = ReiseendeZelle B4 = Reisebeginn

=WENN(C4-B4<WERT(„00:00“);WERT(„24:00“)-B4+C4;C4-B4)

oder:

=C4-B4

V-Pausch.

8-14 Std. = 6,00 €

Zelle D4 = Reisezeit

=WENN(UND(D4>=WERT(„8:00“);D4<WERT(„14:00“));6;0)

V-Pausch.

14-24 Std. = 12,00 €

Zelle D4 = Reisezeit

=WENN(UND(D4>=WERT(„14:00“);D4<WERT(„24:00“));12;0)

V-Pausch.

24 Std. = 24,00 €

Zelle D4 = Reisezeit

=WENN(D4>=WERT(„24:00“);24;0)

Hier meine Reisezeittabelle:

Meine Reisezeittabelle
Meine Reisezeittabell

Die von mir erstellte Reisezeitabelle können Sie hier herunterladen:

Reisezeittabelle


22 Kommentare

  1. Hallo,

    mein Fall ist eine negative Zeit über die Datumsgrenze hinaus. Als Beispiel: Ein Zug kommt planmäßig 00:01 Uhr an. Allerdings ist er zu früh und kommt schon 23:58 Uhr an. Wie kann ich eine Formel umsetzen, sodass die Differenz von -3 Minuten berechnet wird und nicht 1437 Minuten?

    Vielen Dank für die Hilfe!

  2. Tolle Seite und gut erklärte Tabellen…trot aller Mühe hab ich aber noch keine Möglichkeit gefunden wie in der Verpflegungsmehraufwand berechnet werden soll wenn 24 std und mehr also bei einer Montage von 4 oder 5 Tagen die 24 std. zustande kommen.??
    Vielleicht gibt es ja eine Lösung ?

  3. Die Tabelle ist zwar schön aufgebaut Sie rechnet aber leider keine Abwesenheit von mehr als 24 Stunden, bzw. weiß ich nicht wie ich diese angebe.
    Start 09.11., 09:00 Uhr/ Rückkehr 10.11., 18:00 Uhr. Und wie ist es bei mehreren Tagen Abwesenheit z. B. Start 09.11., Rückkehr 12.11., 16:00 Uhr?

    Danke vorab für eine Rückantwort.
    Grüße H. Kirsch

  4. Danke für die Formel. Hat mir sehr geholfen.
    Nur denke ich,daß der letzte Teil +WERT(„24:00“)24 Stunden zuviel ausgibt.
    Wenn ich es weg lasse, paßt es.
    =WENN(B2-A2<WERT("00:00");WERT("24:00")-A2+B2;B2-A2)
    7.3.15 18:15 8.3.15 17:20 23:05 korrekt
    =WENN(B2-A2<WERT("00:00");WERT("24:00")-A2+B2;B2-A2+WERT("24:00"))
    7.3.15 18:15 8.3.15 17:20 47:05 falsch

  5. Die Angaben oben haben mir sehr geholfen. Allerdings scheitere ich immer wieder mal, wenn ich z.B. um Mitternacht losfahre und am selben Tag um Mitternacht wider an komme. Bisher ist mir die Berechnung nur mit Änderen an der Formel geglückt, die dann aber auf den Normalfall nicht mehr anwendbar sind.

    Gruss

    Raimund

  6. Ich suche eine WENN-Funktion in Excel, dass Excel wenn die Uhrzeit zwischen 20:00 Uhr und 24:00 Uhr ist, den WERT in eine andere Zelle mal 25% macht.

  7. Hallo

    Habe auch folgendes Problem

    Habe mir eine eigene Excel Tabelle erstellt (Arbeitszeit), eben auch mit Beginn, Ende, Pausenanfang, Pausenende, Gesamtstunden, Gesamtüberstunden.

    Habe das Problem das ich die Überstunden in Stundenformat und nicht Uhrzeit format brauche, da er das sonst nicht als Summe berechnen kann – gibts da ne Lösung?

    lg

  8. Hallo! Danke für deine antwort. Aber es geht darum, dass ich am 1. Mai um 8 Uhr früh wegfahre und am 2. Mai um 12 Uhr zu Mittag ankomme? Kann ich das in einer formel rechnen?

    1. Also die Reisezeit wird wie folgt ausgerechnet:

      Beispiel:

      A2 = Reisebeginn (08:00 Uhr)
      B2 = Reiseende (12:00 Uhr) bitte auch 12:00 Uhr eingeben

      =WENN(B2-A2<WERT("00:00");WERT("24:00")-A2+B2;B2-A2+WERT("24:00"))

      Wenn das Kopieren der Formel nicht funktioniert dann versuche es selbst einzugeben.

      Wenn Du das Ergebnis hast, musst natürlich die Zelle formatieren. Rufe den Befehl Format, Zellen, Zahlen auf und erstelle folgendes benutzerdefiniertes Zahlenformat: [hh]:mm

      Hoffe Dir geholfen zu haben.

  9. ich denke er hat das selbe Problem wie ich, was bzw wie gebe ich die Formel ein, wenn ich zb länger als 24 Stunden Reise oder meine Reise heute um 8 Uhr früh anfängt und morgen um 12 Uhr endet?!

    Lg t

  10. hallo zusammen,
    die Zeitberechnung ist echt toll erklärt.
    So auch die Reisezeit in Stunden. Wie kann ich jedoch Excel erklären, dass er mir die Stunden genau so berechner die jedoch üner einen Tag (24 STD) hinausgeht?
    Danke für Eure Hilfe.

  11. Hallo! Formel einfach kopieren funkt zwar noch immer nicht – just as info- war aber sehr happy, dass ich die Formel gefunden habe!

    Nur habe ich jetzt das Problem wenn ich dann die Stunden die über zwei Tage gehen addieren möchte – kommen Zahlen/Stunden raus die nicht stimmen. Gibt es hier auch einen Trick?

    Danke schon mal für die Hilfe!

    lg

  12. Hallo,

    also ich habe jetz die Formel ausprobiert. Die Formel stimmt. Excel rechnet ja die Feiertage und Wochenende nicht (hast ja schon geschrieben).

    Wenn Du auch ein Datum eingibst der z.B. Samstag also von 08.01.2011 bis 08.01.2011 dann rechnet das Excel nicht da der 08.01.2011 ein Samstag ist.

    Wenn Du aber z.B. von 08.02.2011 (Dienstag) bis 08.02.2011 (Dienstag) eingibst dann rechnet Excel auch ein Tag als Urlaub.

    Bei mir funktioniert es so, hoffe bei Dir auch. Wenn das Problem weiterhin besteht dann melde dich.

    LG
    Sejla

  13. Hallo Sejla,

    hier die von mir verwendete Formel

    =NETTOARBEITSTAGE(C38;D38;$J$35:$J$44)

    wobei im Bereich J35 bis J44 die Feiertage des aktuellen Jahres stehen
    von 01.01.11 Neujahr bis 26.12.11 2. Weihnachtsfeiertag.

    Vielen Dank schon mal für die Hilfe.

  14. Hallo,

    ich habe irgendwann man eine Exceltabelle mit Excel 2003 oder früher erstellt, in der ich meine Urlaubsplanung mache. Gebe dort Anfangs- und Enddatum ein (Formel Nettoarbeitstage verwendet) und dann wird mir die Anzahl der Urlaubstag (ohne Wochenende und Feiertage) ausgegeben. So weit so gut. Ein Problem besteht nur noch, wenn ich nur einen Tag Urlaub mache und somit Anfangs – und Enddatum gleich sind. Dann wird nicht 1, sondern 0 ausgegeben. Die Lösung des Problems hatte ich schon einmal in Excel 2003 gefunden, aber jetzt sitze ich hier vor Excel 2010 und kann die Lösung nicht finden. Analysefunktion ist schon aktiviert. Kann mir jemand den Trick verraten!?

    1. Hallo,

      sende mir mal die Formel die Du hast. Ich werden dann schauen was mit der Formel nicht stimmt.

      LG
      Sejla

  15. Hallo zusammen, hatte selbiges Thema, muß euch hier sagen das ihr die Formel einfach einfügen könnt; wird ein Wert 00.01.1900 oder 0,28 oder anderer Angezeigt habt Ihr hier lediglich die Zelle in die Ihr die Formel kopiert habt falsch Formatiert!

    Also die Zelle muß natürlich mit dem richtigen Format – hier Uhrzeit formatiert sein! – die Formatierung könnt Ihr auch nach dem Einfügen einstellen.

  16. Danke …

    Da auch ich nicht immer Zeit habe, habe ich mich darauf beschränkt, nur Vorlagen zu erstellen, zu überarbeiten und zu präsentieren.

    Die Anleitungen dazu überlasse ich dir.

    Demnächst werde ich einen entsprechenden Bereich erstellen, die Themen kurz anreißen und dann auf dich verweisen.( nur wenns ok für dich ist)

    Lg
    Jens

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.