Die WENN Funktion ist eine sehr nützliche Funktion. Die Funktion testet eine Bedingung an und gibt dann eines von zwei Ergebnissen je nach Ergebnis der Prüfung an. Der Test muss mit einen richtig oder falsch beantwortet werden.

Zum Beispiel kann ein Test B25 > C30 werden. Wenn das stimmt, dann gibt die WENN Funktion dessen zweites Argument als Ergebnis an. Wenn das falsch ist, wird das dritte Argument zurückgegeben.

WENN Funktion wird oft als ein Überprüfungsschritt verwendet, um unerwünschte Fehler zu vermeiden.

Arbeiten mit der WENN-Funktion

Das Ergebnis einer Berechnung hängt häufig von ganz bestimmten Bedingungen. Wird diese Bedingung  erfüllt, muss eine bestimmte Formel benutzt werden. Wird die Bedingung nicht erfüllt, wird eine alternative Formel eingesetzt. In Excel spricht man dann von einer Wenn-Dann-Sonst-Bedingung.

Damit Excel die Bedingungen umsetzen kann, muss eine bestimmte Schreibweise (Syntax) beachtet werden.

Argument Syntax
Bedingung         

Sollen zwei Angaben oder Werte miteinander verglichen werden, sind Vergleichsoperatoren nötig:

  gleich                        >    größer

<> ungleich                    <=  kleiner gleich

  kleiner                       >=  größer gleich

Prüfung Wird als Wahrheitsprüfung nur ein Feldbezug verwendet, ergibt die Bedingung den Wahrheitswert WAHR, wenn sich in dem Feld ein Wert befindet. Ist das Feld leer, ergibt sich der Wahrheitswert FALSCH.
Dann-Wert Als Dann-Wert kann ein normaler Wert, eine Koordinate, eine Formel oder eine Funktion eingesetzt werden. Soll das Ergebnis ein Text sein, ist dieser in Anführungszeichen zu setzen. Soll das Feld als Ergebnis leer sein, sind direkt hintereinander zwei Anführungszeichen zu setzen.
Sonst-Wert

Für dieses Argument gelten die gleichen Regeln wie für das Argument Dann-Wert.

Tabelle

Tabelle

Beispiel:

  • WENN der Durchschnittsumsatz mehr als 50.000€ beträgt,
  • DANN erhält der Kunde eine Provision von 7% vom Durchschnittsumsatz,
  • SONST beträgt die Provision 5% von Durchschnittsumsatz.

Die Umsatzprovision soll dann mit der WENN-Funktion ausgerechnet werden.

Der Funktionsassistent hilft bei der Auswahl der Funktion und der Bestimmung der richtigen Argumente.

 

Umsatzprovision ausrechnen

  • Klicken Sie auf "Funktion einfügen" und wählen Sie die "WENN-Funktion".
    WENN Funktion einfügen

    WENN Funktion einfügen

  • In Funktionsargument Fenstergeben Sie folgendes ein:
    Funktionsargument Fenster

    Funktionsargument Fenster

  • Klicken Sie auf OK. Somit ist die Umsatzprovision ermittelt.

Die Umsatzprovision kann auch einfach durch die Eingabe von folgender Formel ermittelt werden:

=WENN(B2>50000;B2*7%;B2*5%)

 

Ihre Tipps und Tricks!

Weitere Tipps und Tricks nehme ich gerne in den Kommentaren entgegen.